<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<meta charset="UTF-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<title>2016 Bucs Offensive Unit Final Season Grades | Pewter Report</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.pewterreport.com/xmlrpc.php">
<meta property="og:image" content="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers.jpg"/>
<meta property="og:image:width" content="1024"/>
<meta property="og:image:height" content="1024"/>
<meta property="og:title" content="2016 Bucs Offensive Unit Final Season Grades"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="With the 2016 season wrapped up following a 9-7 record, PewterReport.com takes a look at each individual unit and offers up our grades. Take a look and see if you agree, and comment the story to share"/>
<meta property="og:url" content="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"/>
<meta property="og:site_name" content="Pewter Report"/>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="shortcut icon" href=""/>
<link rel="apple-touch-icon" href="http://www.pewterreport.com/wp-content/uploads/2016/09/apple-touch.jpg"/>
<link rel="pingback" href="http://www.pewterreport.com/xmlrpc.php"/>
<!--[if lt IE 9]>
	<script src="http://www.pewterreport.com/wp-content/themes/goodnews5/framework/helpers/js/html5.js"></script>
	<script src="http://www.pewterreport.com/wp-content/themes/goodnews5/framework/helpers/js/IE9.js"></script>
	<![endif]-->
 
<meta name="description" content="With the 2016 season wrapped up following a 9-7 record, PewterReport.com takes a look at each individual unit and offers up our grades."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="2016 Bucs Offensive Unit Final Season Grades | Pewter Report"/>
<meta property="og:description" content="With the 2016 season wrapped up following a 9-7 record, PewterReport.com takes a look at each individual unit and offers up our grades."/>
<meta property="og:url" content="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"/>
<meta property="og:site_name" content="Pewter Report"/>
<meta property="article:publisher" content="https://www.facebook.com/PewterReport"/>
<meta property="article:author" content="https://www.facebook.com/PewterReport/"/>
<meta property="article:tag" content="Ali Marpet"/>
<meta property="article:tag" content="Dirk Koetter"/>
<meta property="article:tag" content="Jameis Winston"/>
<meta property="article:tag" content="Mike Evans"/>
<meta property="article:tag" content="offense"/>
<meta property="article:tag" content="Season grades"/>
<meta property="article:section" content="Articles"/>
<meta property="article:published_time" content="2017-01-07T20:54:20+00:00"/>
<meta property="fb:app_id" content="1707826629482385"/>
<meta property="og:image" content="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers.jpg"/>
<meta property="og:image:width" content="860"/>
<meta property="og:image:height" content="517"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="With the 2016 season wrapped up following a 9-7 record, PewterReport.com takes a look at each individual unit and offers up our grades."/>
<meta name="twitter:title" content="2016 Bucs Offensive Unit Final Season Grades | Pewter Report"/>
<meta name="twitter:site" content="@pewterreport"/>
<meta name="twitter:image" content="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers.jpg"/>
<meta name="twitter:creator" content="@PewterReport"/>
 
<link rel='dns-prefetch' href='//www.pewterreport.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Pewter Report &raquo; Feed" href="http://www.pewterreport.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Pewter Report &raquo; Comments Feed" href="http://www.pewterreport.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Pewter Report &raquo; 2016 Bucs Offensive Unit Final Season Grades Comments Feed" href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.pewterreport.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='gdbbx-widgets-css' href='http://www.pewterreport.com/wp-content/plugins/gd-bbpress-toolbox/css/widgets.min.css?ver=4.4.5' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.3.0' type='text/css' media='all'/>
<link rel='stylesheet' id='bbppu-css' href='http://www.pewterreport.com/wp-content/plugins/bbpress-pencil-unread/_inc/css/bbppu.css?ver=1.3.0' type='text/css' media='all'/>
<link rel='stylesheet' id='bp-parent-css-css' href='http://www.pewterreport.com/wp-content/themes/goodnews5/css/buddypress.css?ver=2.7.4' type='text/css' media='screen'/>
<link rel='stylesheet' id='wp-ulike-css' href='http://www.pewterreport.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=4.7' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-pagenavi-css' href='http://www.pewterreport.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all'/>
<link rel='stylesheet' id='plugins-css' href='http://www.pewterreport.com/wp-content/themes/goodnews5/css/plugins.css?ver=4.7' type='text/css' media='all'/>
<link rel='stylesheet' id='main-css' href='http://www.pewterreport.com/wp-content/themes/goodnews5/css/main.css?ver=4.7' type='text/css' media='all'/>
<link rel='stylesheet' id='responsive-css' href='http://www.pewterreport.com/wp-content/themes/goodnews5/css/media.css?ver=4.7' type='text/css' media='all'/>
<link rel='stylesheet' id='style-css' href='http://www.pewterreport.com/wp-content/themes/goodnews5/style.css?ver=4.7' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.pewterreport.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all'/>
<link rel='stylesheet' id='redux-google-fonts-mom_options-css' href='http://fonts.googleapis.com/css?family=Play%3A700&#038;ver=1483724284' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.pewterreport.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all'/>
 
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-714428-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');

</script>
 
<script type='text/javascript' src='http://www.pewterreport.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ulike_obj = {"ajaxurl":"http:\/\/www.pewterreport.com\/wp-admin\/admin-ajax.php","button_text_u":"Unlike","button_text":"Like","button_type":"image"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-scripts.min.js?ver=1.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bbppuL10n = {"ajaxurl":"http:\/\/www.pewterreport.com\/wp-admin\/admin-ajax.php","marked_as_read":"Marked as read"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/bbpress-pencil-unread/_inc/js/bbppu.js?ver=1.3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BP_Confirm = {"are_you_sure":"Are you sure?"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-core/js/confirm.min.js?ver=2.7.4'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-core/js/widget-members.min.js?ver=2.7.4'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-core/js/jquery-query.min.js?ver=2.7.4'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-cookie.min.js?ver=2.7.4'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-scroll-to.min.js?ver=2.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BP_DTheme = {"accepted":"Accepted","close":"Close","comments":"comments","leave_group_confirm":"Are you sure you want to leave this group?","mark_as_fav":"Favorite","my_favs":"My Favorites","rejected":"Rejected","remove_fav":"Remove Favorite","show_all":"Show all","show_all_comments":"Show all comments for this thread","show_x_comments":"Show all %d comments","unsaved_changes":"Your profile has unsaved changes. If you leave the page, the changes will be lost.","view":"View"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/buddypress/bp-templates/bp-legacy/js/buddypress.min.js?ver=2.7.4'></script>
<link rel='https://api.w.org/' href='http://www.pewterreport.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.pewterreport.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.pewterreport.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7"/>
<link rel='shortlink' href='http://www.pewterreport.com/?p=983597'/>
<link rel="alternate" type="application/json+oembed" href="http://www.pewterreport.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.pewterreport.com%2F2016-bucs-offensive-unit-grades%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.pewterreport.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.pewterreport.com%2F2016-bucs-offensive-unit-grades%2F&#038;format=xml"/>
 
 
<style type="text/css" media="screen">.g{margin:0px;padding:0px;overflow:hidden;line-height:1;zoom:1;}.g img{height:auto;}.g-col{position:relative;float:left;}.g-col:first-child{margin-left:0;}.g-col:last-child{margin-right:0;}.g-1{margin:15px 0px 15px 0px;width:100%;max-width:720px;height:100%;max-height:90px;}.g-2{margin:0px 0px 0px 0px;width:100%;max-width:300px;height:100%;max-height:250px;}.g-3{margin:0px 0px 0px 0px;width:100%;max-width:300px;height:100%;max-height:250px;}@media only screen and (max-width: 480px) {.g-col,.g-dyn,.g-single{width:100%;margin-left:0;margin-right:0;}}.widget_adrotate_widgets{overflow:hidden;padding:0;}</style>
 
<meta name="generator" content="GD bbPress Toolbox Pro 4.4.5, Build 535"/>
<script type="text/javascript">var ajaxurl = 'http://www.pewterreport.com/wp-admin/admin-ajax.php';</script>
<meta property="fb:pages" content="197475747672"/>
 
<script type="text/javascript">
    /* <![CDATA[ */
    var gdbxRender_Data = { url: "http://www.pewterreport.com/wp-admin/admin-ajax.php", run_quote: true, run_report: false, run_thanks: false, run_attachments: true, run_canned_replies: false, run_bbcodes: true, run_bbcodes_toolbar: false, run_signature: true, run_fitvids: true, wp_editor: true, wp_version: 47, sig_bbcodes: false, limiter: true, max_chars: 512, max_chars_warning: 460, last_cookie: 1483838663, bbpress_version: 25, text_are_you_sure: "Are you sure? Operation is not reversible.", now: 1483836863, validate_attachments: true, insert_into_content: true, max_files: 4, max_size: 524288, allowed_extensions: "jpg jpeg jpe gif png bmp tiff tif ico asf asx wmv wmx wm avi divx flv mov qt mpeg mpg mpe mp4 m4v ogv webm mkv 3gp 3gpp 3g2 3gp2 txt asc c cc h srt csv tsv ics rtx css vtt dfxp mp3 m4a m4b ra ram wav ogg oga mid midi wma wax mka rtf js pdf class tar zip gz gzip rar 7z psd xcf doc pot pps ppt wri xla xls xlt xlw mdb mpp docx docm dotx dotm xlsx xlsm xlsb xltx xltm xlam pptx pptm ppsx ppsm potx potm ppam sldx sldm onetoc onetoc2 onetmp onepkg oxps xps odt odp ods odg odc odb odf wp wpd key numbers pages redux svg", text_select_file: "Select File", text_file_name: "Name", text_file_size: "Size", text_file_type: "Extension", text_file_validation: "Error!", text_file_validation_size: "The file is too big.", text_file_validation_type: "File type not allowed.", text_file_remove: "Remove this file", text_file_shortcode: "Insert into content", text_file_caption: "Set file caption", text_file_caption_placeholder: "Caption..." };
    /* ]]> */
</script>
<style type="text/css">#wpadminbar #wp-admin-bar-gdbb-toolbar .ab-icon:before{content:"\f477";top:2px;}@media screen and ( max-width: 782px ) {#wpadminbar li#wp-admin-bar-gdbb-toolbar{display:block;}}</style>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.pewterreport.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://www.pewterreport.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/amp/"/><style type="text/css" title="dynamic-css" class="options-output">body{color:#000000;}body,body.layout-boxed{background-repeat:no-repeat;background-size:cover;background-attachment:fixed;background-position:center bottom;background-image:url('http://www.pewterreport.com/wp-content/uploads/2014/08/forumbg-1.jpg');}a,h1 a:hover,h2 a:hover,h3 a:hover,h4 a:hover,h5 a:hover,h6 a:hover,.news-ticker li a:hover,.mom-post-meta a:hover,.news-box .older-articles ul li a:hover,.news-box .nb1-older-articles ul li a:hover,.mom-login-widget .lw-user-info a:hover strong,.mpsw-slider ul.slides li .slide-caption:hover,.tagcloud a:hover,.mom-recent-comments .author_comment h4 span a:hover,.widget .twiter-list ul.twiter-buttons li a:hover,.copyrights-text a:hover,ul.main-menu li.mom_mega .mega_col_title a:hover,#navigation .main-menu>li .cats-mega-wrap .subcat .mom-cat-latest li a:hover,#navigation .main-menu>li .cats-mega-wrap .subcat .mom-cat-latest .view_all_posts:hover,.base-box .read-more-link,.widget ul li a:hover,.main_tabs .tabs a.current,.button:hover,.weather-widget .next-days .day-summary .d-date span.dn,.np-posts ul li .details .link:hover,#comments .single-comment .comment-content .comment-reply-link:hover,#comments .single-comment .comment-content .comment-edit-link:hover,.single-author-box .articles-count,.star-rating,.blog-post .bp-head .bp-meta a:hover,ul.main-menu>li:not(.mom_mega) ul.sub-menu li a:hover,.not-found-wrap .ops,#bbpress-forums a,#navigation .main-menu>li:hover>a,#navigation .main-menu>li.current-menu-item>a,#navigation .main-menu>li.current-menu-ancestor>a,#navigation .main-menu>li:hover>a:before,#navigation .main-menu>li.current-menu-item>a:before,#navigation .main-menu>li.current-menu-ancestor>a:before,#navigation ul.device-menu li.dm-active>a,#navigation .device-menu li.dm-active>.responsive-caret,.widget li:hover .cat_num,.news-ticker li i,.mom_breadcrumb .sep,.scrollToTop:hover,ul.products li .mom_product_thumbnail .mom_woo_cart_bt .button:hover,.main_tabs .tabs li.active>a,.toggle_active .toggle_icon:before,#navigation .nav-button.active,.mom-main-color,.mom-main-color a,#buddypress div#item-header div#item-meta a,#buddypress div#subnav.item-list-tabs ul li.selected a,#buddypress div#subnav.item-list-tabs ul li.current a,#buddypress div.item-list-tabs ul li span,#buddypress div#object-nav.item-list-tabs ul li.selected a,#buddypress div#object-nav.item-list-tabs ul li.current a,.mom_bp_tabbed_widgets .main_tabs .tabs a.selected,#buddypress div.activity-meta a.button,.generic-button a,.top_banner a{color:#b0171d;}.mom-social-icons li a.vector_icon:hover,.owl-dot.active span,.feature-slider .fs-nav .selected,#navigation .nav-button.nav-cart span.numofitems{background:#b0171d;}#comments .single-comment .comment-content .comment-reply-link:hover,#comments .single-comment .comment-content .comment-edit-link:hover,.post.sticky{border-color:#b0171d;}h1,h2,h3,h4,h5,h6{color:#231f20;}{color:#b0171d;}.button, #commentform #submit-comment, input[type="submit"], #bbpress-forums #bbp-single-user-details + ul li a, #footer .button, .bbp-search-form #bbp_search_submit{background-color:#b0171d;}.button, #commentform #submit-comment, input[type="submit"], #bbpress-forums #bbp-single-user-details + ul li a, #footer .button, .bbp-search-form #bbp_search_submit{color:#ffffff;}.button:hover, #commentform #submit-comment:hover, input[type="submit"]:hover, #bbpress-forums #bbp-single-user-details + ul li a:hover, #footer .button:hover, .bbp-search-form #bbp_search_submit:hover{color:#000000;}{color:#a5a6a8;}.topbar, .copyrights-area, .topbar .top-nav > li ul.sub-menu li a:hover{background-color:#a5a6a8;}.main-menu > li:not(.current-menu-item):not(.current-menu-ancestor) > a, #navigation .nav-button, .nb-inner-wrap ul.s-results .s-details h4, .nb-inner-wrap .search-results-title, .show_all_results a,  .ajax_search_results .sw-not_found{font-family:Play;font-weight:700;font-style:normal;}{color:#333333;}#footer{background-color:#333333;}{color:#b0171d;}.scrollToTop{background-color:#b0171d;}</style><style type="text/css">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</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>    <link rel='stylesheet' id='wangguard-bp-css'  href='http://www.pewterreport.com/wp-content/plugins/wangguard/css/wangguard-bp.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_reset_css-css'  href='http://www.pewterreport.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='http://www.pewterreport.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='http://www.pewterreport.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='http://www.pewterreport.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='gpoll_css-css'  href='http://www.pewterreport.com/wp-content/plugins/gravityformspolls/css/gpoll.css?ver=3.1' type='text/css' media='all' />
</head>
    <body class="post-template-default single single-post postid-983597 single-format-standard right-sidebar singular layout-boxed fade-imgs-in-appear sticky_navigation_on navigation_highlight_ancestor time_in_twelve_format one-side-wide both-sidebars open_images_in_lightbox wpb-js-composer js-comp-ver-4.12 vc_responsive no-js" itemscope="itemscope" itemtype="http://schema.org/WebPage">
    
        <!--[if lt IE 7]>
            <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
        <![endif]-->
        <div class="boxed-wrap clearfix">
	    <div id="header-wrapper">
                         <div class="topbar">
  <div class="inner">
            <div class="top-left-content">
                 
                         </div> <!--tb left-->
        <div class="top-right-content">
            		    <ul class="mom-social-icons">
                    <li class="twitter"><a target="_blank" class="vector_icon" href="https://twitter.com/pewterreport"><i class="fa-icon-twitter"></i></a></li>
        
                <li class="facebook"><a target="_blank" class="vector_icon" href="https://www.facebook.com/PewterReport"><i class="fa-icon-facebook "></i></a></li>        
        
        
                        <li class="linkedin"><a target="_blank" class="vector_icon" href="https://www.linkedin.com/company/933919"><i class="fa-icon-linkedin"></i></a></li>
        
                        <li class="youtube"><a target="_blank" class="vector_icon" href="https://www.youtube.com/channel/UCwqeh84GMm9Hf7365M9lRYw"><i class="fa-icon-youtube"></i></a></li>
        
                        <li class="instagram"><a target="_blank" class="vector_icon" href="https://www.instagram.com/pewterreport/"><i class="fa-icon-instagram"></i></a></li>
        
        
        

        

        
                                     <li class="rss"><a target="_blank" class="vector_icon" href="http://www.pewterreport.com/feed/"><i class="fa-icon-rss"></i></a></li>
        	
	    </ul>
                    </div> <!--tb right-->
</div>
 </div> <!--topbar-->
             <header class="header " itemscope="itemscope" itemtype="http://schema.org/WPHeader" role="banner">
                <div class="inner">
						                    <div class="logo">
					                    <a href="http://www.pewterreport.com">
		                                                    <img src="http://www.pewterreport.com/wp-content/uploads/2016/08/logo.jpg" alt="Pewter Report" width="400" height="85" />
                                                                                               <img class="mom_retina_logo" src="http://www.pewterreport.com/wp-content/uploads/2016/08/logo.jpg" width="400" height="85" alt="Pewter Report" />
                                                		                    </a>

					
                    </div>
                    <div class="header-right header-right_custom-content" style="margin-top:1px"><div class="g g-1"><div class="g-dyn a-14 c-1"><a onClick="ga('send','event','banner','click','Just Grillin Leaderboard',1,{'nonInteraction':1});" href="http://justgrillinflorida.com/" target="_blank"><img onload="ga('send','event','banner','impression','Just Grillin Leaderboard',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/07/Just-Grillin-tailgate-leaderboard.jpg" /></a></div><div class="g-dyn a-3 c-2"><a onClick="ga('send','event','banner','click','Gerber Collision leaderboard',1,{'nonInteraction':1});" href="https://www.gerbercollision.com/?utm_source=rad&utm_medium=display&utm_campaign=tampa" target="_blank"><img onload="ga('send','event','banner','impression','Gerber Collision leaderboard',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/08/Gerber-leaderboard-728x90.png" /></a></div><div class="g-dyn a-43 c-3"><a onClick="ga('send','event','banner','click','Maximum Audio- Leaderboard- Home',1,{'nonInteraction':1});" href="https://www.maximumav.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Maximum Audio- Leaderboard- Home',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/11/ShopLocal_home_728x90-Sun.jpg" /></a></div><div class="g-dyn a-13 c-4"><a onClick="ga('send','event','banner','click','Holliday Karatinos Leaderboard',1,{'nonInteraction':1});" href="http://www.helpinginjuredpeople.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Holliday Karatinos Leaderboard',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/03/HOLLIDAYKARATINOSLAWFIRMLeaderboard2016Tan.jpg" /></a></div><div class="g-dyn a-20 c-5"><a onClick="ga('send','event','banner','click','IDC Leaderboard 2',1,{'nonInteraction':1});" href="http://www.shopIDC.com/" target="_blank" ><img onload="ga('send','event','banner','impression','IDC Leaderboard 2',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2017/01/IDC-leaderboard-hearts.jpg" /></a></div><div class="g-dyn a-19 c-6"><a onClick="ga('send','event','banner','click','IDC Leaderboard',1,{'nonInteraction':1});" href="http://www.shopIDC.com/" target="_blank" ><img onload="ga('send','event','banner','impression','IDC Leaderboard',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2017/01/IDC-leaderboard-hearts.jpg" /></a></div><div class="g-dyn a-15 c-7"><a onClick="ga('send','event','banner','click','Bucs Leaderboard',1,{'nonInteraction':1});" href="http://www.buccaneers.com/tickets/2017-season-deposits.html" target="_blank"><img onload="ga('send','event','banner','impression','Bucs Leaderboard',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Deposit-728x90-1.jpg" /></a></div></div></div>
                <div class="clear"></div>
                </div>
            </header>
	    	    </div> <!--header wrap-->
                                    <nav id="navigation" itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" role="navigation" class="dd-effect-skew ">
                <div class="navigation-inner">
                <div class="inner">
                                                                <ul id="menu-main" class="main-menu mom_visibility_desktop"><li id="menu-item-493290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home mom_default_menu_item menu-item-iconsOnly menu-item-depth-0"><a href="http://www.pewterreport.com/"><i class="icon_only momizat-icon-home"></i><span class="icon_only_label">Home</span></a></li>
<li id="menu-item-498995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-parent-item mom_mega_cats menu-item-depth-0"><a href="#">News</a><div class='cats-mega-wrap '>
<div class="cats-mega-inner">

<ul class="sub-menu ">
	<li id="menu-item-498635" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/category/articles/">Articles</a></li>
	<li id="menu-item-498868" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/sr/">SR&#8217;s Fab 5</a></li>
	<li id="menu-item-499859" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/pr-mailbag/">PR Mailbag</a></li>
	<li id="menu-item-958613" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/podcastsvideos/">Podcasts/Videos</a></li>
</ul>
<div class='subcat'><div class='active mom-cat-latest' id='mn-latest-498635' data-id='987' data-object='custom' data-layout=''><ul id='mn-ul-latest-498635'><li class='has-thumbnail' ><div class='subcat-thumbnail'><a href='http://www.pewterreport.com/2016-bucs-offensive-unit-grades/' title='2016 Bucs Offensive Unit Final Season Grades'><img src='http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-90x60.jpg' alt='2016 Bucs Offensive Unit Final Season Grades' width='70' height='47'></a></div><div class='subcat-title'><a href='http://www.pewterreport.com/2016-bucs-offensive-unit-grades/' title='2016 Bucs Offensive Unit Final Season Grades'> 2016 Bucs Offensive Unit Final Season Grades</a><span> - 1 min ago</span></div></li><li ><div class='subcat-thumbnail'></div><div class='subcat-title'><a href='http://www.pewterreport.com/983569-2/' title='Cook Talks Bucs And Mike Smith&#8217;s Interviewing On 620 WDAE'> Cook Talks Bucs And Mike Smith&#8217;s Interviewing On 620 WDAE</a><span> - 1 day ago</span></div></li><li class='has-thumbnail' ><div class='subcat-thumbnail'><a href='http://www.pewterreport.com/three-bucs-selected-ap-pro-team/' title='Three Bucs Selected To AP All-Pro Team'><img src='http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-90x60.jpg' alt='Three Bucs Selected To AP All-Pro Team' width='70' height='47'></a></div><div class='subcat-title'><a href='http://www.pewterreport.com/three-bucs-selected-ap-pro-team/' title='Three Bucs Selected To AP All-Pro Team'> Three Bucs Selected To AP All-Pro Team</a><span> - 1 day ago</span></div></li><li class='has-thumbnail' ><div class='subcat-thumbnail'><a href='http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/' title='SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man'><img src='http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-90x60.jpg' alt='SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man' width='70' height='47'></a></div><div class='subcat-title'><a href='http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/' title='SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man'> SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man</a><span> - 1 day ago</span></div></li></ul><a href='http://www.pewterreport.com/category/articles/' title='' class='view_all_posts'>View all<i class='long-arrow-icon'></i></a></div><div class=' mom-cat-latest' id='mn-latest-498868' data-id='1758' data-object='custom' data-layout=''><ul id='mn-ul-latest-498868'></ul><a href='http://www.pewterreport.com/category/sr/' title='' class='view_all_posts'>View all<i class='long-arrow-icon'></i></a></div><div class=' mom-cat-latest' id='mn-latest-499859' data-id='1762' data-object='custom' data-layout=''><ul id='mn-ul-latest-499859'></ul><a href='http://www.pewterreport.com/category/pr-mailbag/' title='' class='view_all_posts'>View all<i class='long-arrow-icon'></i></a></div><div class=' mom-cat-latest' id='mn-latest-958613' data-id='1763' data-object='custom' data-layout=''><ul id='mn-ul-latest-958613'></ul><a href='http://www.pewterreport.com/category/podcastsvideos/' title='' class='view_all_posts'>View all<i class='long-arrow-icon'></i></a></div></div> 
</div>
</div>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-493292" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/about-pewter-report/">About</a></li>
<li id="menu-item-594964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a>Bucs Info</a>
<ul class="sub-menu ">
	<li id="menu-item-594966" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-season-schedule/">Season Schedule</a></li>
	<li id="menu-item-594981" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/nfl-standings/">NFL Standings</a></li>
	<li id="menu-item-594965" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-roster/">Buccaneers Roster</a></li>
	<li id="menu-item-595097" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-coaches/">Buccaneers Coaches</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-503188" class="menu-item menu-item-type-post_type_archive menu-item-object-forum menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/forums/">Boards</a>
<ul class="sub-menu ">
	<li id="menu-item-599562" class="menu-item menu-item-type-post_type_archive menu-item-object-forum mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/forums/">All Forums</a></li>
	<li id="menu-item-599949" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/activity/">Site-Wide Activity</a></li>
	<li id="menu-item-599951" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/members/">Members</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-493289" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/advertise/">Advertise</a></li>
<li id="menu-item-493291" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/contact-us/">Contact</a></li>
</ul>                                                                <div class="device-menu-wrap mom_visibility_device">
                        <div id="menu-holder" class="device-menu-holder">
                            <i class="fa-icon-align-justify mh-icon"></i> <span class="the_menu_holder_area"><i class="dmh-icon"></i>Menu</span><i class="mh-caret"></i>
                        </div>
                        <ul id="menu-main-1" class="device-menu mom_visibility_device"><li id="menu-item-493290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home mom_default_menu_item menu-item-iconsOnly menu-item-depth-0"><a href="http://www.pewterreport.com/"><i class="icon_only momizat-icon-home"></i><span class="icon_only_label">Home</span></a></li>
<li id="menu-item-498995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-parent-item mom_mega_cats menu-item-depth-0"><a href="#">News</a><div class='cats-mega-wrap '>
<div class="cats-mega-inner">

<ul class="sub-menu ">
	<li id="menu-item-498635" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/category/articles/">Articles</a></li>
	<li id="menu-item-498868" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/sr/">SR&#8217;s Fab 5</a></li>
	<li id="menu-item-499859" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/pr-mailbag/">PR Mailbag</a></li>
	<li id="menu-item-958613" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/category/podcastsvideos/">Podcasts/Videos</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-493292" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/about-pewter-report/">About</a></li>
<li id="menu-item-594964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a>Bucs Info</a>
<ul class="sub-menu ">
	<li id="menu-item-594966" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-season-schedule/">Season Schedule</a></li>
	<li id="menu-item-594981" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/nfl-standings/">NFL Standings</a></li>
	<li id="menu-item-594965" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-roster/">Buccaneers Roster</a></li>
	<li id="menu-item-595097" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/buccaneers-coaches/">Buccaneers Coaches</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-503188" class="menu-item menu-item-type-post_type_archive menu-item-object-forum menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/forums/">Boards</a>
<ul class="sub-menu ">
	<li id="menu-item-599562" class="menu-item menu-item-type-post_type_archive menu-item-object-forum mom_default_menu_item active menu-item-depth-1"><a href="http://www.pewterreport.com/forums/">All Forums</a></li>
	<li id="menu-item-599949" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/activity/">Site-Wide Activity</a></li>
	<li id="menu-item-599951" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-1"><a href="http://www.pewterreport.com/members/">Members</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-493289" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/advertise/">Advertise</a></li>
<li id="menu-item-493291" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item menu-item-depth-0"><a href="http://www.pewterreport.com/contact-us/">Contact</a></li>
</ul>                        </div>
                                            		    <div class="nav-buttons">
                                        			<span class="nav-button nav-login">
			    <i class="momizat-icon-users"></i>
			</span>
			<div class="nb-inner-wrap">
			    <div class="nb-inner lw-inner">
			                            <div class="mom-login-widget">
                                                        <form class="mom-login-form" action="http://www.pewterreport.com/wp-login.php" method="post">
					<div class="mom-username">
						<input type="text" name="log" value="" placeholder="username">
					</div>

					<div class="mom-password">
						<input type="password" name="pwd" value="" placeholder="password">
					</div>

					<div class="mom-submit-wrapper">
						<button class="button submit user-submit" name="user-submit" type="submit">Log In</button>
						<input type="checkbox" id="rememberme" name="rememberme" value="forever" >
						<label for="rememberme"><i class="fa-icon-ok"></i>Remember Me</label>
                                                <input type="hidden" name="redirect_to" value="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/" />
					</div>
					                            </form>
                            			    <div class="clear"></div>
                        </div>
			    </div>
			</div>
		    		    
		     
                    <span class="nav-button nav-search">
                        <i class="fa-icon-search"></i>
                    </span>
                    <div class="nb-inner-wrap search-wrap border-box">
                        <div class="nb-inner sw-inner">
                        <div class="search-form mom-search-form">
                            <form method="get" action="http://www.pewterreport.com">
                                <input class="sf" type="text" placeholder="Search ..." autocomplete="off" name="s">
                                <button class="button" type="submit"><i class="fa-icon-search"></i></button>
                            </form>
                            <span class="sf-loading"><img src="http://www.pewterreport.com/wp-content/themes/goodnews5/images/ajax-search-nav.gif" alt="loading..." width="16" height="16"></span>
                        </div>
                    <div class="ajax_search_results">
                    </div> <!--ajax search results-->
                    </div> <!--sw inner-->
                    </div> <!--search wrap-->
                    		
        		    </div> <!--nav-buttons-->
                    
                </div>
                </div> <!--nav inner-->
            </nav> <!--Navigation-->
            	    <div class="boxed-content-wrapper clearfix">
             
            <div class="nav-shaddow"></div>
            
             <div style="margin-top:-17px; margin-bottom:20px;"></div>
            
            <div class="inner">
                            </div>
    <div class="inner">
        
                            <div class="main_container">
           <div class="main-col">
                                <div class="category-title">
                        <div class="mom_breadcrumb breadcrumb breadcrumbs"><div class="breadcrumbs-plus">
<span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.pewterreport.com/" class="home"><span itemprop="title">Home</span></a></span> <span class='separator'><i class="sep fa-icon-double-angle-right"></i></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.pewterreport.com/category/articles/" title="Articles"><span itemprop="title">Articles</span></a></span> <span class='separator'><i class="sep fa-icon-double-angle-right"></i></span> <span itemprop="name">2016 Bucs Offensive Unit Final Season Grades</span></div></div>                </div>
                                        <div class="base-box blog-post p-single bp-horizontal-share post-983597 post type-post status-publish format-standard has-post-thumbnail category-articles category-featured tag-ali-marpet tag-dirk-koetter tag-jameis-winston tag-mike-evans tag-offense tag-season-grades"itemscope itemtype="http://schema.org/Article">
<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
    <meta itemprop="url" content="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-300x180.jpg">
    <meta itemprop="width" content="300">
    <meta itemprop="height" content="300">
  </div>
  <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"/>

  <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
    <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
      <meta itemprop="url" content="http://www.pewterreport.com/wp-content/uploads/2016/08/logo.jpg">
      <meta itemprop="width" content="400">
      <meta itemprop="height" content="85">
    </div>
        <meta itemprop="name" content="Pewter Report">
  </div>
  <meta itemprop="datePublished" content="2017-01-07T20:54:20+00:00"/>
  <meta itemprop="dateModified" content="2017-01-07T20:54:20+00:00"/>


                                   														<div class="feature-img wp-caption">
								<img src="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers.jpg" alt="2016 Bucs Offensive Unit Final Season Grades">
								<p class="wp-caption-text">Bucs WR Mike Evans – Photo by: Cliff Welch/PR</p>
							</div>
							                                   <h1 class="post-tile entry-title" itemprop="headline">2016 Bucs Offensive Unit Final Season Grades</h1>
<div class="mom-post-meta single-post-meta"><span class="author vcard" itemprop="author" itemscope itemtype="https://schema.org/Person">Posted By: <span class="fn" itemprop="name"><a href="http://www.pewterreport.com/author/pewterreportmc/">Mark Cook</a></span></span><span>on: <time datetime="2017-01-07T20:54:20+00:00" class="updated">January 07, 2017</time></span><span><a href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/#respond">No Comments</a></span><div class="post-tools"><a href="javascript:window.print()" rel="nofollow" class="print"><i class="fa-icon-print"> </i>Print</a><a href="mailto:?subject=2016 Bucs Offensive Unit Final Season Grades&body=2016 Bucs Offensive Unit Final Season Grades http://www.pewterreport.com/2016-bucs-offensive-unit-grades/" rel="nofollow" class="email"><i class="fa-icon-envelope"> </i>Email</a></div></div><div class="entry-content">
               <div class="mom-social-share ss-horizontal border-box php-share" data-id="983597">
                    <div class="ss-icon facebook">
                <a href="#" onclick="window.open('http://www.facebook.com/sharer/sharer.php?u=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/', 'Share This', 'menubar=no,toolbar=no,resizable=no,scrollbars=no, width=600,height=455');"><span class="icon"><i class="fa-icon-facebook"></i>Share</span></a>
               <!--  <span class="count"></span> -->
            </div> <!--icon-->
        
                    <div class="ss-icon twitter">
                <a href="http://twitter.com/share?text=2016 Bucs Offensive Unit Final Season Grades&url=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/" onclick="window.open(this.href, 'Post this on twitter', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,width=600,height=455');"><span class="icon"><i class="fa-icon-twitter"></i>Tweet</span></a>
                <!--  <span class="count"></span> -->
            </div> <!--icon-->
        
                    <div class="ss-icon googleplus">
                <a href="#"
onclick="window.open('https://plus.google.com/share?url=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/', '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false"><span class="icon"><i class="fa-icon-google-plus"></i>Share</span></a>
               <!--  <span class="count"></span> -->
            </div> <!--icon-->
                                                <div class="clear"></div>
        </div> <!--social share-->

<br>    <p>With the 2016 season wrapped up following a 9-7 record, PewterReport.com takes a look at each individual unit and offers up our grades. Take a look and see if you agree, and comment the story to share your thoughts.</p>
<p><strong>2016 FINAL OFFENSIVE RANKINGS</strong><br />
<strong>TOTAL OFFENSE:</strong> 18th, 364.4 per game<br />
<strong>PASSING OFFENSE:</strong> 16th,&nbsp;245.4 yards per game<br />
<strong>RUSHING OFFENSE:</strong> 24th,&nbsp;101.0 yards per game<br />
<strong>THIRD DOWN:</strong> 6th,&nbsp;43.72 conversion rate<br />
<strong>SCORING</strong>: 18th, 22.1 points per game<br />
<strong>SACKS:</strong> 17th, 35 sacks allowed</p>
<p><strong>QUARTERBACK</strong><br />
Bucs quarterback Jameis Winston followed up his Bucs rookie record-setting performance with some NFL history, becoming the first quarterback to throw for over 4,000 yards in each of his first two seasons. His 4,090 pass yards and 28 touchdowns also bested Josh Freeman in the team&#8217;s record books, and led the Bucs to their first winning record (9-7) since the 2010 season when Tampa Bay won 10 games.</p>
<div id="attachment_972131" style="width: 310px" class="wp-caption alignleft"><img class="size-medium wp-image-972131" src="http://www.pewterreport.com/wp-content/uploads/2016/11/WINSTONELUDEBEARS-300x185.jpg" alt="" width="300" height="185" srcset="http://www.pewterreport.com/wp-content/uploads/2016/11/WINSTONELUDEBEARS-300x185.jpg 300w, http://www.pewterreport.com/wp-content/uploads/2016/11/WINSTONELUDEBEARS-768x474.jpg 768w, http://www.pewterreport.com/wp-content/uploads/2016/11/WINSTONELUDEBEARS-350x216.jpg 350w, http://www.pewterreport.com/wp-content/uploads/2016/11/WINSTONELUDEBEARS.jpg 860w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Bucs QB Jameis Winston &#8211; Photo by: Mark Lomoglio/PR</p></div>
<p>Despite the accolades and improvements in some areas, Winston also saw his turnovers rise, with 18 interceptions and 10 fumbles, six of which were lost. In his defense, some of the interceptions were desperation throws, (Hail Mary, last second throws etc) but there were plenty that fell directly on him, mainly because of poor decision making. The organization, and Winston himself, knows that he must improve if he wants to see his game rise from good to great.&nbsp;</p>
<p>Inaccuracy was also an issue during games this season, something that also needs to be corrected before he makes the jump, but Winston has pledged to work on these things in the offseason.&nbsp;</p>
<p>With that said, Winston&#8217;s value to the team can&#8217;t be understated. From his leadership, work ethic, ability to help teammates raise their play and other intangibles, Winston is already head and shoulders above where even the most die-hard Winston fans thought he would be after just two seasons. Winston was tough and durable this season, avoided injury, and his uncanny ability to make plays while the pocket broke down bodes well for the future. He certainly can be better, and most likely will be in the future, but for now Bucs fans should rejoice in what appears to be the Bucs finding that elusive franchise quarterback the team has sought since 1976.<br />
<strong>GRADE: B-&nbsp;</strong></p>
<p><strong>RUNNING BACKS</strong><br />
What was expected to be a major strength of the 2016 Buccaneers offense turned out to be an utter disaster marred by injury and after injury, and then capped off with starter Doug Martin being suspended for the final game and the first three of the 2017 season for violating the NFL&#8217;s drug policy.&nbsp;</p>
<p>The duo of Martin and Sims led the NFL in 2015 with combined yards from scrimmage but never came close to replicating their prior success. Martin was injured in Week 2 agains the Cardinals and missed a large chunk of the season, appearing in just eight games and managing just 421 yards (2.9 avg.) on the ground and 134 as a receiver with only three touchdowns.&nbsp;</p>
<div id="attachment_981773" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-981773" src="http://www.pewterreport.com/wp-content/uploads/2016/12/MARTINSIMSCAMPCLIFF-300x181.jpg" alt="" width="300" height="181" srcset="http://www.pewterreport.com/wp-content/uploads/2016/12/MARTINSIMSCAMPCLIFF-300x181.jpg 300w, http://www.pewterreport.com/wp-content/uploads/2016/12/MARTINSIMSCAMPCLIFF-768x463.jpg 768w, http://www.pewterreport.com/wp-content/uploads/2016/12/MARTINSIMSCAMPCLIFF.jpg 860w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Bucs RBs Doug Martin and Charles Sims &#8211; Photo by: Cliff Welch/PR</p></div>
<p>Sims was given the opportunity to be the featured back, but also struggled to find his footing, and missed nine games to injury, finishing with just 149 yards rushing, 190 receiving yards and two scores.&nbsp;</p>
<p>Tampa Bay then turned to Jacquizz Rodgers who played the best of all the backs, but Rodgers was also injured by mid-season and Tampa Bay brought in former Falcons running back Antone Smith, who, you guess it, was also injured.&nbsp;</p>
<p>Undrafted rookie Peyton Barber managed to stay relatively healthy all season for Tampa Bay, but finished with only 223 yards on 51 carries.</p>
<p>The Bucs M*A*S*H unit of running backs ended up averaging 101 yards on the ground through 16 games in 2016, but the uncertainty of Martin&#8217;s return means the Bucs will likely look to add talent at that position this offseason. While some of the struggles can be traced to inconstant line play, the backs themselves played a part in the inability to have an impact as well.<br />
<strong>GRADE: C-</strong></p>
<p><strong>WIDE RECEIVERS</strong><br />
For Tampa Bay Bucs wide receivers, 2016 was defined by Mike Evans, injuries and lesser-known names trying to fill voids. The Week 5 injury to Vincent Jackson exposed the team’s depth issues at the position further.</p>
<p>Evans solidified himself as one of the NFL’s top receivers and he turned in a huge year despite opposing secondaries keying in on him throughout the season. Evans posted career-highs in receptions (96) and yards (1,321) and tied his franchise-record mark of 12 touchdown catches originally set as a rookie in 2014. Knowing he possessed a limited number of quality targets to work with, Winston sometimes forced passes to Evans to try and get his playmaker’s hands on the ball as much as possible. This led to Evans receiving an NFL-high 173 targets but owning a low 55.5 percent catch rate.</p>
<div id="attachment_980371" style="width: 310px" class="wp-caption alignleft"><img class="size-medium wp-image-980371" src="http://www.pewterreport.com/wp-content/uploads/2016/12/EvansMI-300x179.jpg" alt="" width="300" height="179" srcset="http://www.pewterreport.com/wp-content/uploads/2016/12/EvansMI-300x179.jpg 300w, http://www.pewterreport.com/wp-content/uploads/2016/12/EvansMI-768x459.jpg 768w, http://www.pewterreport.com/wp-content/uploads/2016/12/EvansMI.jpg 860w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">WR Mike Evans – Photo by: Getty Images</p></div>
<p>When Jackson was lost to injury, slot receiver Adam Humphries became Winston’s second-best option at the position. The second-year pro doesn’t have the size or skillset necessary to be much of a field-stretching threat, but he is reliable and shifty enough to pick up a few extra yards on catches made in space. Humphries caught 55 of his 83 targets (66.3 percent catch rate) for 622 yards and two touchdowns. He saved his best for last when he snagged a career-high 10 receptions for 94 yards Week 17 against the Carolina Panthers.</p>
<p>Winton’s other receivers throughout the year were Russell Shepard (23 catches for 341 yards and two touchdowns), Cecil Shorts (11 for 152), Freddie Martino (eight for 142, one score), and Josh Huff (three for 41). Despite missing the last 11 games, Jackson finished fourth on the team among receivers with 15 catches for 173 yards.</p>
<p>Speed will be the theme most likely this offseason when the Bucs look to upgrade their receiving corps. Fortunately for Tampa Bay and GM Jason Licht, this draft appears to be deep for playmakers who can burn.&nbsp;<br />
<strong>GRADE: B-</strong></p>
<p><strong>TIGHT ENDS</strong><br />
The tight end position got a big, early shakeup when Austin Seferian-Jenkins burned his final bridge in Tampa Bay and got the boot after playing sparingly in the first two games. Although Cameron Brate was already beginning to settle in atop the depth chart prior to Seferian-Jenkins’ unceremonious departure, the cut made it imperative for Brate to step up.</p>
<p>Head coach Dirk Koetter preferred Brate to begin with and the Harvard grad rewarded him with a borderline Pro Bowl-worthy effort. Brate finished tied with San Diego rookie Hunter Henry for the NFL lead in touchdowns by a tight end, with eight, and his 57 receptions for 660 yards ranked him second behind Mike Evans among Buccaneers pass catchers.</p>
<div id="attachment_977426" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-977426" src="http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-300x189.jpg" alt="" width="300" height="189" srcset="http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-300x189.jpg 300w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-768x483.jpg 768w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-120x76.jpg 120w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-265x168.jpg 265w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-284x180.jpg 284w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-274x173.jpg 274w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate-220x140.jpg 220w, http://www.pewterreport.com/wp-content/uploads/2016/12/CamBrate.jpg 860w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">TE Cameron Brate – Photo by: Cliff Welch/PR</p></div>
<p>Coming into camp with a bulked up physique, Brate also made positive strides improving his run- and pass-blocking abilities. Those stat-less responsibilities were primarily tasked to Brandon Myers and Luke Stocker again. Myers played all 16 games and Stocker suited up for 13. Considering the Bucs rushing attack fell to 24th in the NFL (101 yards per game, 3.6 yards per attempt) and Winston was hit 108 times (fifth-most) and sacked 35 times, everyone tasked with blocking deserves a little bit of blame in that regard. In the passing game, Myers finished with eight catches for 59 yards and one touchdown, and Stocker caught five passes for 23 yards.</p>
<p>The Bucs also received a spirited effort from undrafted rookie Alan Cross. The tight end/fullback started the year on the practice squad but played sporadically throughout the final 14 games. Cross ended up with six receptions for 38 yards and caught his first NFL touchdown during Tampa Bay’s Week 11 win in Kansas City.<br />
<strong>GRADE: B</strong></p>
<p><strong>OFFENSIVE LINE</strong><br />
Inconsistent would be the word that best described&nbsp;the Bucs offensive line in 2016. At times they could be dominate, then a series later have two penalties, a tackle for loss on a running play, and then a third down sack. And it wasn&#8217;t just one player, all the linemen seemed to take turns making technique and mental errors, and a lot of the time, at the worst possible time.&nbsp;</p>
<div id="attachment_983454" style="width: 310px" class="wp-caption alignleft"><img class="size-medium wp-image-983454" src="http://www.pewterreport.com/wp-content/uploads/2017/01/MARPETRUNBLOCKSAINTS-300x184.jpg" alt="" width="300" height="184" srcset="http://www.pewterreport.com/wp-content/uploads/2017/01/MARPETRUNBLOCKSAINTS-300x184.jpg 300w, http://www.pewterreport.com/wp-content/uploads/2017/01/MARPETRUNBLOCKSAINTS-768x471.jpg 768w, http://www.pewterreport.com/wp-content/uploads/2017/01/MARPETRUNBLOCKSAINTS.jpg 860w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Bucs RG Ali Marpet &#8211; Photo by: Cliff Welch/PR</p></div>
<p>The inconsistency can somewhat be blamed on some injuries this season, starting with free agent J.R. Sweezy who never saw the field for the Bucs after coming over from the Seahawks. Tampa Bay had planned on Sweezy taking over for a retired Logan Mankins, but a back injury kept him sidelined all season. Kevin Pamphile filled in surprisingly well by most accounts, and while he was part of the inconsistency issues at times, his development in 2016 should pay dividends down the road. Pamphile was injured with a concussion and missed two games&nbsp;this season, along with Demar Dotson who was also knocked out for action for three games. Center Joe Hawley was banged up for most of the season, missing one game, along with backup center Evan Smith who missed time with a knee injury.&nbsp;</p>
<p>As noted above, the Bucs running game took a step back last season, partly because of the shuffled lineup due to injuries and the up and down play of the offensive line. Pass protection wise, it was much of the same, with some very good games followed up by games where Winston was running for his life.</p>
<p>It is easy to lay all the blame on the offensive line, and there is no question that some is due their way. But if you ask Dirk Koetter, and Winston, they both will tell you, they like the personnel currently, especially with younger players like Ben Gottschalk and Caleb Benenoch gaining experience this season.</p>
<p>Addressing the line, as some fans are clamoring for, is easier said then done. The draft isn&#8217;t top heavy with top caliber talent, and the free agent maker most likely will be thin, which means the few players that make it that far will get paid big time most likely. The Bucs most likely star pat and hope Sweezy can return and provide some stability and more importantly, more leadership lost when Mankins retired.<br />
<strong>GRADE: C&nbsp;</strong></p>
          
       <div class="mom-social-share ss-horizontal border-box php-share" data-id="983597">
                    <div class="ss-icon facebook">
                <a href="#" onclick="window.open('http://www.facebook.com/sharer/sharer.php?u=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/', 'Share This', 'menubar=no,toolbar=no,resizable=no,scrollbars=no, width=600,height=455');"><span class="icon"><i class="fa-icon-facebook"></i>Share</span></a>
               <!--  <span class="count"></span> -->
            </div> <!--icon-->
        
                    <div class="ss-icon twitter">
                <a href="http://twitter.com/share?text=2016 Bucs Offensive Unit Final Season Grades&url=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/" onclick="window.open(this.href, 'Post this on twitter', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,width=600,height=455');"><span class="icon"><i class="fa-icon-twitter"></i>Tweet</span></a>
                <!--  <span class="count"></span> -->
            </div> <!--icon-->
        
                    <div class="ss-icon googleplus">
                <a href="#"
onclick="window.open('https://plus.google.com/share?url=http://www.pewterreport.com/2016-bucs-offensive-unit-grades/', '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false"><span class="icon"><i class="fa-icon-google-plus"></i>Share</span></a>
               <!--  <span class="count"></span> -->
            </div> <!--icon-->
                                                <div class="clear"></div>
        </div> <!--social share-->

</div> <!-- entry content -->
</div> <!-- base box -->

            <div class="np-posts">
                <ul>
			                    <li class="np-post prev border-box">
						<div class="post-img">
                            <a href="http://www.pewterreport.com/983569-2/"><img src="" data-hidpi="" alt="2016 Bucs Offensive Unit Final Season Grades"></a>
                        </div>
			                        <div class="details has-feature-image">
                            <a href="http://www.pewterreport.com/983569-2/" class="link prev"><i class="fa-icon-double-angle-left"></i>Previous</a>
                            <h3><a href="http://www.pewterreport.com/983569-2/">Cook Talks Bucs And Mike Smith&#8217;s Interviewing On 620 WDAE</a></h3>
                        </div>
                    </li>
		    		                    </ul>
            </div> <!-- np posts -->
		<div class="mom-e3lanat-wrap responsive ">
	<div class="mom-e3lanat " style="">
		<div class="mom-e3lanat-inner">
		
				<div class="mom-e3lan" data-id="928642" style="width:px; height:autopx;  ">
		<div class="e3lan-code"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Article Bottom -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6114677105545158"
     data-ad-slot="5766119823"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	</div><!--mom ad-->
			</div>
	</div>	<!--Mom ads-->
	</div>
<h2 class="single-title">About the author</h2>
            <div class="base-box single-box about-the-author">
                <div class="author_avatar"><img src="//www.gravatar.com/avatar/528901270195238cd768c94b05ddbcdd?s=80&#038;r=g&#038;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg" class="avatar user-32299-avatar avatar-80 gravatar" width="80" height="80" alt="Profile gravatar of Mark Cook" id='avatar-user'   /></div>
                <div class="author_desc">
                    <h3 calss="vcard author"><span class="fn"><a href="http://www.pewterreport.com/author/pewterreportmc/">Mark Cook</a></span>  </span></h3>
        <p>
		Mark Cook currently is the director of editorial content and Bucs beat writer and has written for PewterReport.com since 2011. Cook has followed the Buccaneers since 1977 when he first began watching football with his Dad and is fond of the 1979 Bucs team that came within 10 points of going to a Super Bowl. His favorite Bucs game is still the 1979 divisional playoff win 24-17 over the Eagles. In his spare time Cook enjoys playing guitar, fishing, surfing and family time at the beach. In addition, Cook can be found in front of a television or in Doak Campbell any time the FSU Seminoles are playing. Cook is a native of Pinecrest in Eastern Hillsborough County and has written for numerous publications including the Tampa Tribune, In the Field and Ya'll Magazine. Cook can be reached at mark@pewterreport.com	</p>
                 <div class="mom-socials-icons author-social-icons">
        <ul>
                                        <li class="facebook"><a target="_blank" href="https://www.facebook.com/PewterReport/"><i class="fa-icon-facebook "></i></a></li>                    <li class="twitter"><a target="_blank" href="https://twitter.com/PewterReport"><i class="fa-icon-twitter"></i></a></li>                                       <li class="rss"><a target="_blank" href="http://www.pewterreport.com/author/pewterreportmc/feed/"><i class="fa-icon-rss"></i></a></li>
                    <li class="youtube"><a target="_blank" href="https://www.youtube.com/channel/UCwqeh84GMm9Hf7365M9lRYw"><i class="fa-icon-youtube"></i></a></li>                                                                                <li class="instgram"><a target="_blank" href="https://www.instagram.com/pewterreport/?hl=en"><i class="fa-icon-instagram"></i></a></li>                                                                    </u>

        <div class="clear"></div>
    </div>

                </div>
	            <div class="clear"></div>

            </div>
                <h2 class="single-title">Related Articles</h2>
            <div class="base-box single-box">
                <ul class="single-related-posts">
	   	     	       <li>
			                        <h4><a itemprop="name" href="http://www.pewterreport.com/983569-2/">Cook Talks Bucs And Mike Smith&#8217;s Interviewing On 620 WDAE</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2017-01-06T17:30:26+00:00">January 06, 2017</time>
			</div>
                </li>

	       <li>
			                        <a href="http://www.pewterreport.com/three-bucs-selected-ap-pro-team/"><img src="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-190x122.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-610x380.jpg" alt="Three Bucs Selected To AP All-Pro Team"></a>
			                        <h4><a itemprop="name" href="http://www.pewterreport.com/three-bucs-selected-ap-pro-team/">Three Bucs Selected To AP All-Pro Team</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2017-01-06T17:16:18+00:00">January 06, 2017</time>
			</div>
                </li>

	       <li>
			                        <a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/"><img src="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-190x122.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-610x380.jpg" alt="SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man"></a>
			                        <h4><a itemprop="name" href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/">SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2017-01-06T10:43:45+00:00">January 06, 2017</time>
			</div>
                </li>

</ul>
</div>

<div id="comments" class="comments-area">

	
			
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2016-bucs-offensive-unit-grades/#respond" style="display:none;">Cancel Reply</a></small></h3><p class="must-log-in">You must be <a href="http://www.pewterreport.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.pewterreport.com%2F2016-bucs-offensive-unit-grades%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->            </div> <!--main column-->
                        <div class="clear"></div>
</div> <!--main container-->            
            <div class="sidebar main-sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
            		   	    <div class="custom_textwidget">
				<div class="g g-2"><div class="g-dyn a-33 c-1"><a onClick="ga('send','event','banner','click','Sports Legends square',1,{'nonInteraction':1});" href="http://couponbutter.com/account/get-coupon/?coupon_id=MTQ4Mjg2NTAyOA==&user_id=NTI=" target="_blank" ><img onload="ga('send','event','banner','impression','Sports Legends square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/pewter_report.png" /></a></div><div class="g-dyn a-38 c-2"><a onClick="ga('send','event','banner','click','Hard Rock square',1,{'nonInteraction':1});" href="http://seminolehardrocktampa.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Hard Rock square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Hard-Rock-calendar.jpg" /></a></div><div class="g-dyn a-8 c-3"><a onClick="ga('send','event','banner','click','Brandon Auto square',1,{'nonInteraction':1});" href="http://www.brandonauto.com" target="_blank"><img onload="ga('send','event','banner','impression','Brandon Auto square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2014/09/Brandon-Auto-square-banner.jpg" /></a></div><div class="g-dyn a-48 c-4"><a onClick="ga('send','event','banner','click','Gulf Coast Tractor square',1,{'nonInteraction':1});" href="http://www.gulfcoasttractor.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Gulf Coast Tractor square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Gulf-Coast-Tractor.jpg" /></a></div><div class="g-dyn a-12 c-5"><a onClick="ga('send','event','banner','click','Holliday Karatinos Square',1,{'nonInteraction':1});" href="http://www.helpinginjuredpeople.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Holliday Karatinos Square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/03/HOLLIDAYKARATINOSLAWFIRMSquare2016.jpg" /></a></div><div class="g-dyn a-27 c-6"><a onClick="ga('send','event','banner','click','Metro Development Group square',1,{'nonInteraction':1});" href="https://www.metroplaces.com/ " target="_blank"><img onload="ga('send','event','banner','impression','Metro Development Group square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/07/metro_banner_300x2502.gif" /></a></div><div class="g-dyn a-41 c-7"><a onClick="ga('send','event','banner','click','Just Grillin square',1,{'nonInteraction':1});" href="http://justgrillinflorida.com/" target="_blank"><img onload="ga('send','event','banner','impression','Just Grillin square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/09/Just-Grillin-tailgate-square.jpg" /></a></div><div class="g-dyn a-47 c-8"><a onClick="ga('send','event','banner','click','Brewlands square',1,{'nonInteraction':1});" href="http://www.brewlandsbilliards.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Brewlands square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Brewlands-square-version-1.jpg" /></a></div><div class="g-dyn a-45 c-9"><a onClick="ga('send','event','banner','click','Jennifer Zales square',1,{'nonInteraction':1});" href="http://www.tampabayluxuryhomes.com/" target="_blank"><img onload="ga('send','event','banner','impression','Jennifer Zales square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/11/Jennifer-Zales-square.jpg" /></a></div><div class="g-dyn a-34 c-10"><a onClick="ga('send','event','banner','click','Helicon square',1,{'nonInteraction':1});" href="http://www.heliconusa.com/" target="_blank"><img onload="ga('send','event','banner','impression','Helicon square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/08/Helicon-square.jpg" /></a></div></div>			  </div>


<div style="height:20px;"></div>		   	    <div class="custom_textwidget">
				<div id="pewterpoll">
<a href="https://www.gerbercollision.com/?utm_source=rad&utm_medium=display&utm_campaign=tampa" target="_blank"><img src="/images/pewterpoll.jpg"></a>
<div id="gravity">

                <div class='gf_browser_unknown gform_wrapper gpoll_enabled_wrapper gpoll_show_results_link_wrapper gpoll_block_repeat_voters_wrapper gpoll_wrapper' id='gform_wrapper_28' ><a id='gf_28' class='gform_anchor' ></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_28' id='gform_28' class='gpoll_enabled gpoll_show_results_link gpoll_block_repeat_voters gpoll' action='/2016-bucs-offensive-unit-grades/#gf_28'>
                        <div class='gform_body'><ul id='gform_fields_28' class='gform_fields top_label form_sublabel_below description_below'><li id='field_28_2' class='gfield field_sublabel_below field_description_below gfield_visibility_visible gpoll_field' ><label class='gfield_label'  >What is your opinion of the Bucs 2016 season?</label><div class='ginput_container ginput_container_radio'><ul class='gfield_radio' id='input_28_2'><li class='gchoice_28_2_0'><input name='input_2' type='radio' value='Exceeded expectations'  id='choice_28_2_0' tabindex='1'    /><label for='choice_28_2_0' id='label_28_2_0'>Exceeded expectations</label></li><li class='gchoice_28_2_1'><input name='input_2' type='radio' value='Met expectations'  id='choice_28_2_1' tabindex='2'    /><label for='choice_28_2_1' id='label_28_2_1'>Met expectations</label></li><li class='gchoice_28_2_2'><input name='input_2' type='radio' value='Failed to meet expectations'  id='choice_28_2_2' tabindex='3'    /><label for='choice_28_2_2' id='label_28_2_2'>Failed to meet expectations</label></li><li class='gchoice_28_2_3'><input name='input_2' type='radio' value='Other'  id='choice_28_2_3' tabindex='4'    /><label for='choice_28_2_3' id='label_28_2_3'>Other</label></li></ul></div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_28' class='gform_button button' value='Submit' tabindex='5' onclick='if(window["gf_submitting_28"]){return false;}  window["gf_submitting_28"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_28"]){return false;} window["gf_submitting_28"]=true;  jQuery("#gform_28").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=28&amp;title=&amp;description=&amp;tabindex=1' />
            <input type='hidden' class='gform_hidden' name='is_submit_28' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='28' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_28' value='WyJbXSIsImE3M2M2MjIwYmYyNzc2ZmY2YzZkY2IwYzgzMmM1ZjQxIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_28' id='gform_target_page_number_28' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_28' id='gform_source_page_number_28' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_28' id='gform_ajax_frame_28'>This iframe contains the logic required to handle AJAX powered Gravity Forms.</iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 28, 'http://www.pewterreport.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_28').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_28');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_28').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_28').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_28').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_28').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_28').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_28').val();gformInitSpinner( 28, 'http://www.pewterreport.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [28, current_page]);window['gf_submitting_28'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('#gforms_confirmation_message_28').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_28').replaceWith('<' + 'div id=\'gforms_confirmation_message_28\' class=\'gform_confirmation_message_28 gforms_confirmation_message\'' + '>' + confirmation_content + '<' + '/div' + '>');jQuery(document).scrollTop(jQuery('#gforms_confirmation_message_28').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [28]);window['gf_submitting_28'] = false;}, 50);}else{jQuery('#gform_28').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [28, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"http:\/\/www.pewterreport.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"http:\/\/www.pewterreport.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 28) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [28, 1]) } ); </script></div></div>			  </div>


<div style="height:20px;"></div><div class="widget widget_text"><div class="widget-head"><h3 class="widget-title"><span>NFC South</span></h3></div>			<div class="textwidget">
<table id="tablepress-2" class="tablepress tablepress-id-2">
<thead>
<tr class="row-1 odd">
	<th class="column-1">Team</th><th class="column-2">W</th><th class="column-3">L</th>
</tr>
</thead>
<tbody class="row-hover">
<tr class="row-2 even">
	<td class="column-1">Falcons</td><td class="column-2">11</td><td class="column-3">5</td>
</tr>
<tr class="row-3 odd">
	<td class="column-1">Buccaneers</td><td class="column-2">9</td><td class="column-3">7</td>
</tr>
<tr class="row-4 even">
	<td class="column-1">Saints</td><td class="column-2">7</td><td class="column-3">9</td>
</tr>
<tr class="row-5 odd">
	<td class="column-1">Panthers</td><td class="column-2">6</td><td class="column-3">10</td>
</tr>
</tbody>
</table>
</div>
		</div>		   	    <div class="custom_textwidget">
				<script type="text/javascript" src="//ap.lijit.com/www/delivery/fpi.js?z=399336&u=pewterreport&width=300&height=250"></script>			  </div>


<div style="height:20px;"></div><div class="widget bbp_widget_login"><div class="widget-head"><h3 class="widget-title"><span>Forum Login</span></h3></div>
			<form method="post" action="http://www.pewterreport.com/wp-login.php" class="bbp-login-form">
				<fieldset>
					<legend>Log In</legend>

					<div class="bbp-username">
						<label for="user_login">Username: </label>
						<input type="text" name="log" value="" size="20" id="user_login" tabindex="101" />
					</div>

					<div class="bbp-password">
						<label for="user_pass">Password: </label>
						<input type="password" name="pwd" value="" size="20" id="user_pass" tabindex="102" />
					</div>

					<div class="bbp-remember-me">
						<input type="checkbox" name="rememberme" value="forever"  id="rememberme" tabindex="103" />
						<label for="rememberme">Remember Me</label>
					</div>

					<div class="bbp-submit-wrapper">

						
						<button type="submit" name="user-submit" id="user-submit" tabindex="104" class="button submit user-submit">Log In</button>

						
		<input type="hidden" name="user-cookie" value="1" />

		<input type="hidden" id="bbp_redirect_to" name="redirect_to" value="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/" /><input type="hidden" id="_wpnonce" name="_wpnonce" value="a7b2572607" /><input type="hidden" name="_wp_http_referer" value="/2016-bucs-offensive-unit-grades/" />
					</div>

					
						<div class="bbp-login-links">

							
								<a href="http://www.pewterreport.com/wp-login.php?action=register" title="Register" class="bbp-register-link">Register</a>

							
							
								<a href="http://www.pewterreport.com/wp-login.php?action=lostpassword" title="Lost Password" class="bbp-lostpass-link">Lost Password</a>

							
						</div>

					
				</fieldset>
			</form>

		</div>		   	    <div class="custom_textwidget">
				<div class="g g-2"><div class="g-dyn a-33 c-1"><a onClick="ga('send','event','banner','click','Sports Legends square',1,{'nonInteraction':1});" href="http://couponbutter.com/account/get-coupon/?coupon_id=MTQ4Mjg2NTAyOA==&user_id=NTI=" target="_blank" ><img onload="ga('send','event','banner','impression','Sports Legends square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/pewter_report.png" /></a></div><div class="g-dyn a-38 c-2"><a onClick="ga('send','event','banner','click','Hard Rock square',1,{'nonInteraction':1});" href="http://seminolehardrocktampa.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Hard Rock square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Hard-Rock-calendar.jpg" /></a></div><div class="g-dyn a-6 c-3"><a onClick="ga('send','event','banner','click','Bespoke &amp; Co. square',1,{'nonInteraction':1});" href="http://www.bespokeandcofl.com" target="_blank"><img onload="ga('send','event','banner','impression','Bespoke &amp; Co. square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2015/07/Bespoke-square.jpg" /></a></div><div class="g-dyn a-41 c-4"><a onClick="ga('send','event','banner','click','Just Grillin square',1,{'nonInteraction':1});" href="http://justgrillinflorida.com/" target="_blank"><img onload="ga('send','event','banner','impression','Just Grillin square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/09/Just-Grillin-tailgate-square.jpg" /></a></div><div class="g-dyn a-8 c-5"><a onClick="ga('send','event','banner','click','Brandon Auto square',1,{'nonInteraction':1});" href="http://www.brandonauto.com" target="_blank"><img onload="ga('send','event','banner','impression','Brandon Auto square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2014/09/Brandon-Auto-square-banner.jpg" /></a></div><div class="g-dyn a-45 c-6"><a onClick="ga('send','event','banner','click','Jennifer Zales square',1,{'nonInteraction':1});" href="http://www.tampabayluxuryhomes.com/" target="_blank"><img onload="ga('send','event','banner','impression','Jennifer Zales square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/11/Jennifer-Zales-square.jpg" /></a></div><div class="g-dyn a-46 c-7"><a onClick="ga('send','event','banner','click','Bascom\&#039;s square',1,{'nonInteraction':1});" href="http://www.bascoms.com//" target="_blank" ><img onload="ga('send','event','banner','impression','Bascom\&#039;s square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Bascoms-square.jpg" /></a></div><div class="g-dyn a-47 c-8"><a onClick="ga('send','event','banner','click','Brewlands square',1,{'nonInteraction':1});" href="http://www.brewlandsbilliards.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Brewlands square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/12/Brewlands-square-version-1.jpg" /></a></div><div class="g-dyn a-27 c-9"><a onClick="ga('send','event','banner','click','Metro Development Group square',1,{'nonInteraction':1});" href="https://www.metroplaces.com/ " target="_blank"><img onload="ga('send','event','banner','impression','Metro Development Group square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/07/metro_banner_300x2502.gif" /></a></div><div class="g-dyn a-12 c-10"><a onClick="ga('send','event','banner','click','Holliday Karatinos Square',1,{'nonInteraction':1});" href="http://www.helpinginjuredpeople.com/" target="_blank" ><img onload="ga('send','event','banner','impression','Holliday Karatinos Square',2,{'nonInteraction':1});" src="http://www.pewterreport.com/wp-content/uploads/2016/03/HOLLIDAYKARATINOSLAWFIRMSquare2016.jpg" /></a></div></div>			  </div>


<div style="height:20px;"></div><div class="widget momizat-news_letter"><div class="widget-head"><h3 class="widget-title"><span>Newsletter</span></h3></div>                        <div class="mom-newsletter ">
                            <h4>Subscribe to our email newsletter.</h4>
			    			    <form action="" class="mn-form mom_mailchimp_subscribe" method="post" data-list_id="5b482b64dc">
                                <i class="mn-icon brankic-icon-envelope"></i><input name="email" class="mms-email" type="text" placeholder="Enter your e-mail ..">
				<span class="sf-loading"><img src="http://www.pewterreport.com/wp-content/themes/goodnews5/images/ajax-search-nav.gif" alt="loading..." width="16" height="16"></span>

                                <button class="button" type="submit">Subscribe</button>

                            </form>
		
                        </div>
</div>
           </div> <!--main sidebar-->
            <div class="clear"></div>                      </div> <!--main inner-->
            
      </div> <!--content boxed wrapper-->
                        <footer id="footer">
                <div class="inner">
	     			<div class="one_third">
		<div class="widget momizat-posts"><div class="widget-head"><h3 class="widget-title"><span>Recent Posts</span></h3></div>                                   <div class="mom-posts-widget">

					<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"><img src="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-90x60.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-90x60.jpg" alt="2016 Bucs Offensive Unit Final Season Grades" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/"><img src="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-180x120.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2017/01/EvansTDPanthers-180x120.jpg" alt="2016 Bucs Offensive Unit Final Season Grades" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="http://www.pewterreport.com/2016-bucs-offensive-unit-grades/">2016 Bucs Offensive Unit Final Season Grades</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2017-01-07T20:54:20+00:00" class="entry-date">January 07, 2017</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="http://www.pewterreport.com/983569-2/">Cook Talks Bucs And Mike Smith&#8217;s Interviewing On 620 WDAE</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2017-01-06T17:30:26+00:00" class="entry-date">January 06, 2017</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="http://www.pewterreport.com/three-bucs-selected-ap-pro-team/"><img src="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-90x60.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-90x60.jpg" alt="Three Bucs Selected To AP All-Pro Team" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="http://www.pewterreport.com/three-bucs-selected-ap-pro-team/"><img src="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-180x120.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2016/11/EVANS-1-180x120.jpg" alt="Three Bucs Selected To AP All-Pro Team" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="http://www.pewterreport.com/three-bucs-selected-ap-pro-team/">Three Bucs Selected To AP All-Pro Team</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2017-01-06T17:16:18+00:00" class="entry-date">January 06, 2017</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/"><img src="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-90x60.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-90x60.jpg" alt="SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/"><img src="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-180x120.jpg" data-hidpi="http://www.pewterreport.com/wp-content/uploads/2017/01/AGUAYOKICKCOWBOYS-180x120.jpg" alt="SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/">SR&#8217;s Fab 5: Bucs&#8217; Aguayo Not As Bad As You Think; Spence Became A Marked Man</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2017-01-06T10:43:45+00:00" class="entry-date">January 06, 2017</span>
			    			    </div>
			</div>
			</div> <!--//post-->

									                                    </div>
</div>
			</div><!-- End third col -->
			<div class="one_third">
		<div class="widget momizat-twitter"><div class="widget-head"><h3 class="widget-title"><span>Twitter</span></h3></div>				<ul class="twiter-list">
				                                <li class="twiter-list-item">
					<div class="tl-head">
                                   <a target="_blank" href="https://twitter.com/PewterReport"><img src="http://pbs.twimg.com/profile_images/508982757729386496/Cuzda3Lt_normal.jpeg" width="48" height="48" alt="pewterreport_avatar"></a>
                                   <span class="twitter-user-name"><a target="_blank" href="https://twitter.com/PewterReport">@PewterReport</a><time>3 hours ago</time>
</span>
                                   <a class="twiter-follow" href="https://twitter.com/intent/follow?screen_name=PewterReport" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Follow</a>
					</div> <!--head-->
                                   <div class="twiter-tweet">
					What did some current <a target='_blank' href="http://twitter.com/#search?q=Bucs" class="twitter-link">#Bucs</a> say about potential draftees for Tampa Bay? Read a new SR's Fab 5. <a target='_blank' href="https://t.co/H83GKUnNy2" class="twitter-link">https://t.co/H83GKUnNy2</a>				   </div>
                                   <ul class="twiter-buttons">
                                        <li class="replay"><a href="https://twitter.com/intent/tweet?in_reply_to=817885028696854528" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Replay</a></li>
                                        <li class="retweet"><a href="https://twitter.com/intent/retweet?tweet_id=817885028696854528" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Retweet</a></li>
                                        <li class="favorite"><a href="https://twitter.com/intent/favorite?tweet_id=817885028696854528" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Favorite</a></li>
                                   </ul>
                                </li>
				                                <li class="twiter-list-item">
					<div class="tl-head">
                                   <a target="_blank" href="https://twitter.com/PewterReport"><img src="http://pbs.twimg.com/profile_images/508982757729386496/Cuzda3Lt_normal.jpeg" width="48" height="48" alt="pewterreport_avatar"></a>
                                   <span class="twitter-user-name"><a target="_blank" href="https://twitter.com/PewterReport">@PewterReport</a><time>1 hour ago</time>
</span>
                                   <a class="twiter-follow" href="https://twitter.com/intent/follow?screen_name=PewterReport" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Follow</a>
					</div> <!--head-->
                                   <div class="twiter-tweet">
					How did Noah Spence feel about his first NFL season, what did Aguayo say about his struggles? Read a new SR's Fab 5! <a target='_blank' href="https://t.co/H83GKUFopA" class="twitter-link">https://t.co/H83GKUFopA</a>				   </div>
                                   <ul class="twiter-buttons">
                                        <li class="replay"><a href="https://twitter.com/intent/tweet?in_reply_to=817854579958124544" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Replay</a></li>
                                        <li class="retweet"><a href="https://twitter.com/intent/retweet?tweet_id=817854579958124544" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Retweet</a></li>
                                        <li class="favorite"><a href="https://twitter.com/intent/favorite?tweet_id=817854579958124544" onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false">Favorite</a></li>
                                   </ul>
                                </li>
				
                            </ul>
	</div>			</div><!-- End third col -->
			<div class="one_third last">
		<div class="widget momizat-recent_comments"><div class="widget-head"><h3 class="widget-title"><span>Recent Comments</span></h3></div>  <div class="mom-recent-comments">
                            <ul>
                                <li>
                                    <div class="author_avatar border-box">
                                        <a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36538" title="Naplesfan on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man"><img alt='' src='http://1.gravatar.com/avatar/a173a9c710bd41506c168a6120368905?s=60&#038;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&#038;r=g' srcset='http://1.gravatar.com/avatar/a173a9c710bd41506c168a6120368905?s=120&amp;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&amp;r=g 2x' class='avatar avatar-60 gravatar' height='60' width='60' /></a>
                                    </div>
                                    <div class="author_comment">
                                    <h4><a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36538" title="Naplesfan on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man">Naplesfan</a> <time>on 07 Jan </time><span class="rc-post">in: <a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/">SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man</a></span></h4>
                                    <p>Bucnut2 - whether Aguayo is an effective kicker has nothing to do wher ... </p>
<!--                         <a class="read-more-link" href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36538" title="Naplesfan on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man">Read more</a>
 -->                                    </div>
                                </li>
                                                          <li>
                                    <div class="author_avatar border-box">
                                        <a href="http://www.pewterreport.com/bucs-bring-two-former-texas-aggies/#comment-36537" title="macabee on Bucs Bring On Two Former Texas A&M Aggies"><img alt='' src='http://1.gravatar.com/avatar/7b0b4e404e417344638cd26fad473689?s=60&#038;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&#038;r=g' srcset='http://1.gravatar.com/avatar/7b0b4e404e417344638cd26fad473689?s=120&amp;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&amp;r=g 2x' class='avatar avatar-60 gravatar' height='60' width='60' /></a>
                                    </div>
                                    <div class="author_comment">
                                    <h4><a href="http://www.pewterreport.com/bucs-bring-two-former-texas-aggies/#comment-36537" title="macabee on Bucs Bring On Two Former Texas A&M Aggies">macabee</a> <time>on 07 Jan </time><span class="rc-post">in: <a href="http://www.pewterreport.com/bucs-bring-two-former-texas-aggies/">Bucs Bring On Two Former Texas A&M Aggies</a></span></h4>
                                    <p>I hope those Aggie connections workout. The Aggie connection I would b ... </p>
<!--                         <a class="read-more-link" href="http://www.pewterreport.com/bucs-bring-two-former-texas-aggies/#comment-36537" title="macabee on Bucs Bring On Two Former Texas A&M Aggies">Read more</a>
 -->                                    </div>
                                </li>
                                                          <li>
                                    <div class="author_avatar border-box">
                                        <a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36536" title="Garv on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man"><img alt='' src='http://2.gravatar.com/avatar/ec12be2129bc6985bd3feae583efbf46?s=60&#038;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&#038;r=g' srcset='http://2.gravatar.com/avatar/ec12be2129bc6985bd3feae583efbf46?s=120&amp;d=http%3A%2F%2Fwww.pewterreport.com%2Fwp-content%2Fuploads%2F2016%2F08%2Favatar-1.jpg&amp;r=g 2x' class='avatar avatar-60 gravatar' height='60' width='60' /></a>
                                    </div>
                                    <div class="author_comment">
                                    <h4><a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36536" title="Garv on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man">Garv</a> <time>on 07 Jan </time><span class="rc-post">in: <a href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/">SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man</a></span></h4>
                                    <p>Wrong. He "fell" to the Buccaneers because of a molly incident at Ohio ... </p>
<!--                         <a class="read-more-link" href="http://www.pewterreport.com/srs-fab-5-bucs-aguayo-not-as-bad-as-you-think-spence-became-a-marked-man/#comment-36536" title="Garv on SR's Fab 5: Bucs' Aguayo Not As Bad As You Think; Spence Became A Marked Man">Read more</a>
 -->                                    </div>
                                </li>
                          
                            </ul>
        </div>
</div>
			</div><!-- End third col -->
	        

        <div class="clear"></div>                    
                </div> <!--// footer inner-->
            </footer> <!--//footer-->
            <div class="copyrights-area">
                <div class="inner">
                    <p class="copyrights-text">© 2016 PewterReport.com All Rights reserved.  <a href="http://www.thevisualrealm.com/">Tampa Web Design</a> | Visual Realm</p>
                    <ul id="menu-footer" class="footer_menu"><li id="menu-item-493347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493347"><a href="http://www.pewterreport.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-493348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493348"><a href="http://www.pewterreport.com/advertise/">Advertise</a></li>
<li id="menu-item-493349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493349"><a href="http://www.pewterreport.com/contact-us/">Contact</a></li>
</ul>				                <div class="responsive-toggle">
                	<a class="desktop-version" href="?responsive=false">Desktop Version</a>
                	<a class="mobile-version" href="?responsive=true">Mobile Version</a>
                </div>
                                </div>
           </div>
            <div class="clear"></div>
        </div> <!--Boxed wrap-->
        <a href="#" class="scrollToTop button"><i class="enotype-icon-arrow-up"></i></a>	        <!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-plugins.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-includes/js/comment-reply.min.js?ver=4.7'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/bbpress/templates/default/js/editor.js?ver=2.5.12-6148'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201701'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/themes/goodnews5/js/plugins.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var momAjaxL = {"url":"http:\/\/www.pewterreport.com\/wp-admin\/admin-ajax.php","nonce":"2b12ff13d0","success":"check your email to complete subscription","error":"Already subscribed","error2":"Email invalid","werror":"Enter a valid city name.","nomore":"No More Posts","homeUrl":"http:\/\/www.pewterreport.com","viewAll":"View All","noResults":"Sorry, no posts matched your criteria","bodyad":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/themes/goodnews5/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/js_composer/assets/lib/prettyphoto/js/jquery.prettyPhoto.min.js?ver=4.12'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-includes/js/wp-embed.min.js?ver=4.7'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.1.2'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gpollVars = {"ajaxurl":"http:\/\/www.pewterreport.com\/wp-admin\/admin-ajax.php","imagesUrl":"http:\/\/www.pewterreport.com\/wp-content\/plugins\/gravityformspolls\/images"};
var gpoll_strings = {"viewResults":"View results","backToThePoll":"Back to the poll"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/gravityformspolls/js/gpoll.js?ver=3.1'></script>
<script type='text/javascript' src='http://www.pewterreport.com/wp-content/plugins/tablepress/js/jquery.datatables.min.js?ver=1.7'></script>
<script type="text/javascript">
jQuery(document).ready(function($){
$('#tablepress-2').dataTable({"order":[],"orderClasses":false,"stripeClasses":['even','odd'],"paging":false,"searching":false,"info":false});
});
</script><!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 60000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 20000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

    </body>
</html>